Le Transfert Pellicule... Index du Forum

Le Transfert Pellicule...
Méthode de transfert Pellicule : 8 mm - Super 8 - 9,5 mm - 16 mm - Projecteur - Condenseur - Camescope - Optique...

 FAQFAQ   RechercherRechercher   MembresMembres   GroupesGroupes   S’enregistrerS’enregistrer 
 ProfilProfil   Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 

mon téléciné à base de Raspberry et arduino
Aller à la page: <  1, 2
 
Poster un nouveau sujet   Répondre au sujet    Le Transfert Pellicule... Index du Forum -> TRANSFERT PELLICULE SUPER 8 (Forum Public) -> Transfert sans Condenseur
Sujet précédent :: Sujet suivant  
Auteur Message
jcgrini
Fondateurs

Hors ligne

Inscrit le: 19 Mar 2008
Messages: 6 077
Localisation: NICE
Masculin
Point(s): 0

MessagePosté le: Jeu 28 Sep 2017 - 17:36    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Il semble que l'on peut faire faire une marche arrière à un film avec une correction négative. Dans un logiciel de correction ou de montage.
_________________
@+
Jean Claude
http://vimeo.com/5251678
http://letransfertpellicule.free.fr/
----------------------------------------------------------


Dernière édition par jcgrini le Jeu 28 Sep 2017 - 19:47; édité 1 fois
Revenir en haut
Visiter le site web du posteur
Publicité






MessagePosté le: Jeu 28 Sep 2017 - 17:36    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Balzac_40


Hors ligne

Inscrit le: 06 Mai 2017
Messages: 18
Localisation: La Rochelle
Masculin Lion (24juil-23aoû) 蛇 Serpent
Point(s): 0

MessagePosté le: Jeu 28 Sep 2017 - 19:29    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Sur mon projecteur Heurtier P53 (8 mm) on ne peut pas faire marche arrière car dans ce cas, le film n'est pas correctement positionné. Dans mon programme, j'ai reprise l'astuce de Joe HERMAN, à savoir revenir de n+1 images en arrière, puis d'avancer d'une image pou le bon positionnement.

Ceci dit, j'ai tenté aujourd'hui le film inversé (en faisant un premier rembobinage à contresens) ; j'ai aussi laissé à neutre la correction de netteté...

Il me semble que les craquelures sont moins visibles, mais sans plus.


Ancienne (par l'arrière, mais avec netteté au maximum ou presque)


Pas loin du découragement total...
_________________
Sur le métier sans cesse remettons notre ouvrage...


Revenir en haut
Visiter le site web du posteur
jcgrini
Fondateurs

Hors ligne

Inscrit le: 19 Mar 2008
Messages: 6 077
Localisation: NICE
Masculin
Point(s): 0

MessagePosté le: Jeu 28 Sep 2017 - 19:48    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Je parlais correction marche arriere dans un logiciel de correction.
_________________
@+
Jean Claude
http://vimeo.com/5251678
http://letransfertpellicule.free.fr/
----------------------------------------------------------


Revenir en haut
Visiter le site web du posteur
jempi13


Hors ligne

Inscrit le: 04 Mar 2010
Messages: 391
Point(s): 0

MessagePosté le: Jeu 28 Sep 2017 - 20:24    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonsoir,

les craquelures sont moins visibles, mais la mise au point n'est pas nette... je dirais que les craquelures sont floutées comme le reste.
Sur un logiciel de montage, il suffit d'appliquer en général une vitesse de -100%.

Jean-Pierre.


Revenir en haut
Balzac_40


Hors ligne

Inscrit le: 06 Mai 2017
Messages: 18
Localisation: La Rochelle
Masculin Lion (24juil-23aoû) 蛇 Serpent
Point(s): 0

MessagePosté le: Lun 2 Oct 2017 - 13:18    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour,

J'ai fait quelques essais, toujours à partir des captures similaires aux images postées ci-dessus... (autrement dit, pas très nettes, avec plein de craquelures, rayures et taches).

J'ai limité l'image à 960x720, de sorte à pouvoir utiliser Net Video en mode démo.

Puis j'ai soumis ce film à Film9 (que je ne maîtrise pas encore, loin de là).

Cela donne ceci au final, en format allégé pour Youtube (court extrait).

Pouvez-vous me donner votre avis ?

C'est ici :
https://youtu.be/wB7g97I8LJU



Merci à tous pour votre écoute, et votre... gentillesse, et... votre patience !
Jean-Luc
_________________
Sur le métier sans cesse remettons notre ouvrage...


Revenir en haut
Visiter le site web du posteur
jempi13


Hors ligne

Inscrit le: 04 Mar 2010
Messages: 391
Point(s): 0

MessagePosté le: Lun 2 Oct 2017 - 20:06    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonsoir Jean-Luc,

On ne voit plus de craquelures, les couleurs sont franches (elle l'étaient déjà) et des tons bien définis, c'est au premier coup d'œil très joli, mais cela présente beaucoup de lissage, un peu comme on en voyait sur des cassettes VHS. En fait il n'y a plus de grain.
Il y a aussi quelques zones brouillées dans les zones où les mouvements se superposent.
Cela risque de se voir beaucoup sur grand écran.

Je pense que la correction est trop poussée, on ne peut pas tout imputer à YouTube, il faut trouver la bonne mesure, réduire le rayon d'action de la correction peut-être si c'est le principe auquel je pense.

La matériau de base serait vraiment très bon si on ne voyait pas autant les craquelures, je suggèrerais de travailler sur le diffuseur en premier afin de pouvoir appliquer une correction moins énergique

Prendre son temps, faire des essais...

Jean-Pierre.
Les membres suivants remercient jempi13 pour ce message :
Balzac_40 (02/10/17)


Revenir en haut
Stef44


Hors ligne

Inscrit le: 22 Mai 2014
Messages: 422
Localisation: Loire Atlantique
Masculin
Point(s): 0

MessagePosté le: Mar 3 Oct 2017 - 09:40    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Voire appliquer un petit wetgate... Ca peut boucher les rayures. Mais comme jempi, là le film est (beaucoup) trop lissé. (pour moi ^^)
Les membres suivants remercient Stef44 pour ce message :
Balzac_40 (03/10/17)


Revenir en haut
Gelinox


Hors ligne

Inscrit le: 05 Fév 2012
Messages: 203
Localisation: Suisse
Masculin
Point(s): 0

MessagePosté le: Mar 3 Oct 2017 - 13:55    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Effectivement, je trouve aussi que le film est trop lissé.

Si je peux me permettre, je pense que tu devrais commencer par le traitement avec Film9, en gardant le format de l'image (projet/garder les dimensions du clip source).
Car, si tu stabilises l'image avec Film9, tu n'auras pas les bordures du film qui bougent au final.
Perso, je désactiverais les options AutoWhite et Autogain
Tu peux aussi faire l'impasse sur le traitement du grain avec Film9, puisque tu utilises Neat.

Ensuite avec Neat, le traitement des craquelures est très efficace et devrait suffire.
Et c'est à ce stade qu'il faut brider la puissance de Neat, car il dégraine très très fort, ce logiciel.

Et peut-être aussi appliquer au final une petite correction de couleur, le jaune est bien présent sur ton film.


_________________
@+
Gelinox
http://vimeo.com/user15168846

----------------------------------------------------------


Revenir en haut
jcgrini
Fondateurs

Hors ligne

Inscrit le: 19 Mar 2008
Messages: 6 077
Localisation: NICE
Masculin
Point(s): 0

MessagePosté le: Mar 3 Oct 2017 - 19:49    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Balzac_40
je t'ai corrigé le lien pour avoir la vidéo sur la discussion. la balise [media] ne fonctionne pas.

même avis, tu as trop poussé le lissage. .
_________________
@+
Jean Claude
http://vimeo.com/5251678
http://letransfertpellicule.free.fr/
----------------------------------------------------------
Les membres suivants remercient jcgrini pour ce message :
Balzac_40 (06/10/17)


Revenir en haut
Visiter le site web du posteur
Balzac_40


Hors ligne

Inscrit le: 06 Mai 2017
Messages: 18
Localisation: La Rochelle
Masculin Lion (24juil-23aoû) 蛇 Serpent
Point(s): 0

MessagePosté le: Ven 6 Oct 2017 - 13:40    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour,

Merci à vous tous ; vos avis sont précieux et sont autant d'encouragements à poursuivre.

Je crois que j'arrive à quelques "conclusions" toutes personnelles :
    1 - Pour du format 8 millimètres normal, des captures en 960x720 me semblent suffisantes ; aller au delà n'apporte rien de bon.
    D'autres que moi démontrent je crois que le format SD correspond vraiment au 8mm. (surface de l'image 8mm x densité de pixels)
    Ceci permet peut-être d'avoir un meilleur résultat ? Et accessoirement, gain de place disque et temps...

    2 - Il ne faut pas chercher à forcer la netteté lors de la prise de vue ; tout ce qu'on obtient, c'est encore plus de défauts !
    Il est vrai que celui qui m'a donné envie d'essayer cette approche précisait bien ce point et conseillait de diminuer au maximum la netteté de caméra du RaspberryPi.
    Pour avoir essayé, j'ai pu constater qu'effectivement, les craquelures sont de fait moins difficiles à éliminer.

    3 - Neat Video est un outil qu'il faut aussi apprendre à utiliser.
    Pour le test que je vous ai soumis précédemment, je n'avais pas encore découvert les presets de et outil !
    J'ai fait un nouvel essai aussi avec le script AVS Film Restoration de Videofred...
    Et je trouve plutôt bluffant le résultat !


Bref, on est pas encore rendu !

Jean-Luc
_________________
Sur le métier sans cesse remettons notre ouvrage...


Revenir en haut
Visiter le site web du posteur
vmp


Hors ligne

Inscrit le: 24 Aoû 2014
Messages: 140
Localisation: Paris
Masculin
Point(s): 0

MessagePosté le: Dim 14 Jan 2018 - 17:21    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour William,


Ta réalisation a évolué par rapport à la présentation faite au début de cette discussion, et je pense comme toi qu’il serait intéressant de faire profiter les membres du forum de nos quelques échanges récents en MP.


Cela d’autant plus que l’utilisation d’un Raspberry Pi semble beaucoup attirer l’attention : 2000 vues en 3 mois : je ne serais pas surpris que d’aucun soit en train de travailler sur le sujet…


De mon côté voici la raison de mon intérêt pour cette solution :
Comme tu peux le voir sur le forum, avec l’aide et les conseils de membres très actifs, j’ai réalisé il y a maintenant deux ans un transfert synchrone à 12,5 images/seconde qui me donne entière satisfaction
http://letransfert.soforums.com/t979-r-alisation-d-une-capture-synchrone-12…

J’atteins par une autre méthode un objectif identique, à savoir une image video pour une image film. Tout en reconnaissant que ta méthode permet une meilleure restitution de la dynamique du film original.


Mais… car il y un mais !
J’ai une centaine de bobines à numériser, j’en suis à peu près à la moitié, et, si ma méthode présente l’énorme avantage de numériser plus vite, elle a cependant l’inconvénient de mobiliser ma caméra, et je crains de finir par la « fatiguer » à force de travailler dans des conditions un peu trop éloignées de sa destination première. Quelques premiers signes m’incitent à lever le pied !


C’est pourquoi je me suis intéressé à ta solution à base de caméra + raspberry Pi, avec en prime l’occasion de plonger dans ce monde complètement nouveau pour moi que sont cette petite carte, les OS et les applications associés.
Seulement dans ce cas il me faut absolument arriver à augmenter la vitesse de numérisation : plusieurs images/seconde (une dizaine/secondes ?)


La caméra Arducam a attiré mon attention car selon la doc il semble y avoir une possibilité de synchroniser la caméra (signaux FREX et STROBE). Il y a même un signal Vsynch disponible sur la plaquette de la caméra.
Mon idée première était de m’en servir pour synchroniser mon projecteur. Au lieu de travailler image par image, je pensais configurer l’Arducam en mode video et utiliser le signal Vsync de la même manière que le signal video issu de ma caméra actuelle.



Idée première = idée trop simpliste, car ce signal est toujours à 0, et après avoir pas mal fouillé sur le web, il semble que personne n’ait réussi à en tirer quelque chose, ni non plus des signaux FREX et STROBE.
La caméra d’Arducam est compatible des caméras Pi, ni plus ni moins !


La seule solution serait donc d’utiliser la caméra en mode image, comme tu le fais, en cherchant le meilleur compromis entre temps d’exposition, temps de traitement (lié à la définition de l'image) et nombre d’images par seconde, et de voir à quelle vitesse le système décroche.
Sur les différentes réalisations que j'ai pu trouver sur le web, la notion de vitesse de numérisation ne semble pas avoir été prise en compte dans leur cahier des charges.
Au chapitre 6 de la doc de la Pi camera on trouve quelques informations sur le fonctionnement de la caméra (http://picamera.readthedocs.io/en/release-1.13/license.html).


Si quelqu’un a un retour d’expérience sur ce point …


vmp


Revenir en haut
Balzac_40


Hors ligne

Inscrit le: 06 Mai 2017
Messages: 18
Localisation: La Rochelle
Masculin Lion (24juil-23aoû) 蛇 Serpent
Point(s): 0

MessagePosté le: Dim 14 Jan 2018 - 18:56    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour à tous/toutes !

Le message de vmp m'invite à revenir donner des nouvelles ! Et vous souhaiter une bonne année !

Je me suis beaucoup investi dans l'impression 3D, car je voulais continuer d'avancer dans ce projet. Mais je me suis un peu laissé prendre par cette technologie à découvrir.

Du côté de Joe Herman (https://github.com/jphfilm/rpi-film-capture/tree/master) je reste dans l'impasse car la solution ne fonctionne pas, et les avancées annoncées en octobre... sont toujours en attente !

De mon côté, voici mes dernières réflexions :

1 - j'ai fait l'acquisition d'un objectif qui sert normalement pour filmer des sujets microscopiques. On obtient ainsi une image en pleine résolution. Jusque là, j'étais limité à une capture partielle sur le capteur. (pour du 8mm normal)
https://fr.aliexpress.com/item/Free-shipping-industry-microscope-camera-C-mount-lens-glass-1X-100X-Magnification-Adjustable-2-4mm-36mm/32704763459.html?spm=a2g0s.9042311.0.0.N4WD74

2 - j'ai voulu tester la caméra V2.1 de Raspberry Pi (8 Mp) : pour faire simple fiasco total de ce côté là (pour CET usage, avec CET objectif décrit ci-dessus).
Et là des images avec un halo central que je n'ai pas su corriger après des heures d'essais... Et beaucoup de corrections du module picamera qui restent sans effet, et aucun piqué...



3 - je viens de revenir donc à la caméra V1 (5 MP) (en fait un clone permettant le montage d'un objectif CS).
Je suis revenu à la prise de vue par l'arrière et j'ai modifié ma source de lumière (led puissante blanc presque froid) et j'ai créé un diffuseur en PLA transparent (merci l'imprimante 3D) qui se termine par une pointe de cône...
Et là, grosses surprises :
- images en 2592x1944 (réduites en 1440x1080)
- craquelures devenues quasi-invisibles, rayures bien atténuées
- possibilité de pousser au maximum le sharpness pour un meilleur piqué
- aucune correction nécessaire sauf peut-être un petit plus sur l'exposition...

Par ailleurs, j'ai revu la prise de photos en utilisant le port vidéo et non plus le port dédié à la photo...
C'est l'écriture de l'image (via réseau local dans mon cas) qui ralentit le processus...

Il me reste à améliorer la gestion du moteur pas à pas, et trouver une solution pour stocker plus vite les images car aujourd'hui, je suis à tout juste une image/seconde.





Voilà où j'en suis...

Au plaisir d'échanger avec vous.
Jean-Luc
_________________
Sur le métier sans cesse remettons notre ouvrage...


Revenir en haut
Visiter le site web du posteur
remibora


Hors ligne

Inscrit le: 26 Déc 2017
Messages: 2
Localisation: lyon
Masculin
Point(s): 0

MessagePosté le: Mar 23 Jan 2018 - 23:27    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour,
Tout comme vous, je me suis lancé dans la bataille et pour l'instant il y a match nul (c'est pas mal mais j’espérais mieux).
J'ai essayé de suivre vos conseils (capture pleine résolution, diffuseur (qui jaunit légèrement l'image malheureusement), spot leds blanc froid fait maison,...).
Mais je reste bloqué au niveau de l'utilisation du logiciel Film9.
En effet, malgré de nombreuses tentatives (film généré en 16ips avec VirtualDub puis interpolé ou non avec Film9, compressé ou non...) je ne parviens jamais à générer un film complet.
Je n'obtiens que le début du film: sur 32 images à 16ips, je n'ai que les 7 premières (traitement sans interpolation). Lors du process, il se produit 2 "passes": la 1ere de 11 images et la 2nde de 7 images (qui doit correspondre au résultat final).
Pour information, j'ai testé sous windows10-64bits, Win7-64bits,Win7-32bits.
Je souhaiterai donc savoir si quelqu'un a déjà observé ce problème.
D'avance merci.
Rémi.
PS: Concernant la vitesse, je suis également "bloqué" à environ 1 ips (76 i/min pour être précis) en enregistrant au format JPEG 100%. Même en enregistrant sur la carte SD du Raspberry et en JPEG à 80%, je ne réduis pas beaucoup cette vitesse d'acquisition.
Par contre, je n'ai pas compris la remarque de Balzac_40 au sujet du port dédié à la photo et le port vidéo. Il me semblait que la caméra ne pouvait se connecter que sur le port DSI...


Revenir en haut
jcgrini
Fondateurs

Hors ligne

Inscrit le: 19 Mar 2008
Messages: 6 077
Localisation: NICE
Masculin
Point(s): 0

MessagePosté le: Mer 31 Jan 2018 - 19:50    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Un site à connaître
http://randomnerdtutorials.com/best-raspberry-pi-camera-for-your-project/
_________________
@+
Jean Claude
http://vimeo.com/5251678
http://letransfertpellicule.free.fr/
----------------------------------------------------------


Revenir en haut
Visiter le site web du posteur
remibora


Hors ligne

Inscrit le: 26 Déc 2017
Messages: 2
Localisation: lyon
Masculin
Point(s): 0

MessagePosté le: Dim 4 Fév 2018 - 17:36    Sujet du message: mon téléciné à base de Raspberry et arduino Répondre en citant

Bonjour,
Je dois remercier GillesH (Film9) pour m'avoir indiqué l'erreur que j'ai commise. Bien évidemment, il fallait cocher Avec synchro (dans le type de capture) dans les paramètres du projet Film9.
Encore un immense merci.
Rémi


Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 03:58    Sujet du message: mon téléciné à base de Raspberry et arduino

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Le Transfert Pellicule... Index du Forum -> TRANSFERT PELLICULE SUPER 8 (Forum Public) -> Transfert sans Condenseur Toutes les heures sont au format GMT + 1 Heure
Aller à la page: <  1, 2
Page 2 sur 2

 
Sauter vers:  

Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com